Decreasing an Android App’s Min SDK

There comes a point in any project where, for some reason, you have to do something you really don’t want to do. If you haven’t experienced this, you’re either very lucky or just bloody stubborn. The dreaded day came for me. The initial app was supporting Lollipop (API 21) and onwards. We had to now […]

Backwards Compatibility of MarginLeft and Margin Right

TL;DR – Boring and monotonous, find & replace process. If someone has some tips to reduce the manual nature of the below process, please shout! As part of an effort to add backwards compatibility to a project, (reducing the minimum Android version from 21 to 16), one of the hurdles was adding support for the […]